Linux installation problems with VIA C3 Samuel 2 EDEN

If you attempt to install a newer Linux distribution with this processor you will get the following message:

This kernel requires the following features not present on the CPU:
cx8 cmov

Use a kernel before version 2.6.35. In these versions the CPU extension for “Conditional Move” is not necessary.